正在加载...


因 php Hash碰撞

特此升级了 php  5.3.9 升级过程一切正常,安装加载 pdo_mysql 扩展 也没问题,全部完事后运行 phpinfo() 函数

This is The PHP Code
<?php
phpinfo();
?>
Parsed in 0.050 seconds at 381 B/s

结果发现没pdo_mysql没加载上,启动时候也没报错,日志也没任何错误信息。

放到 php 5.2.17 就没问题,于是怀疑版本兼容问题,就重新下载 PDO_MYSQL

结果还是一样,

This is The Code
[root@selboo.com.cn ~]# /usr/local/php-5.3.9/bin/php -m

PHP Warning:  PHP Startup: pdo_mysql: Unable to initialize module
Module compiled with module API=20060613
PHP    compiled with module API=20090626
These options need to match
in Unknown on line
Parsed in 0.000 seconds at N/A

后来发现 http://pecl.php.net/package/PDO_MYSQL 并不是最新版本,

最新版本以整合到 php 5.3.9 安装包内,

进入 php-5.3.9/ext/pdo_mysql 目录重新编译安装后解决
最后编辑: selboo 编辑于2012/01/30 15:55
Tags: , ,
,
发表评论
表情
打开HTML
打开UBB
打开表情
隐藏
记住我
昵称   密码   游客无需密码
网址   电邮   [注册]